Puppy Linux

Information on installing into Puppy500 and Puppy528 at:
http://www.murga-linux.com/puppy/viewtopic.php?p=571758#571758

An alternative for 5.28 by Ty Tower http://murga-linux.com/puppy/viewtopic.php?p=580187#580187 Note I have not gotten this to work for 5.3 Slacko only 5.28

20/1/2013 UPDATE by Ty Tower........In Puppy Precise 5.4.2 I have used Arduino Version 1.0.3 and they say the messy downloads are not required .I think this is because the new Atmel tool chain has them included see http://www.avrfreaks.net/modules.php?op=modload&name=News&file=article&sid=970&mode=thread&order=0&thold=0

You must have java JRE the java runtime environment. At this time there is no java ".sfs" that I have seen for 5.4.2 so you may get the java JRE here http://www.oracle.com/technetwork/java/javase/downloads/index.html ,it installs in /usr/bin/ on mine and you must change your PATH in your profile to use it. Go to /etc/.profile and find "PATH=" line and add "/usr/java/jre1.6.0_38/bin/:" into the line.Save Please note the menues don't seem to work with 1.7 java but with 1.6 they are useable so I use 1.6.

. Then get Arduino 1.0.3 http://arduino.googlecode.com/files/arduino-1.0.3-linux32.tgz. It installs in / I moved the whole lot to /opt/ .Open the Arduino dir and drag the file "arduino" onto your desktop. You can edit the desktop icon to put the Arduino icon there .It is in /arduino/reference/img Reboot.

Share